Follow

WE.L.D.E.R. is not compatible with my current iOS.

The current version of W.E.L.D.E.R. requires OS 10.7 "Lion" to run. We are actively working on an update that will solve any compatibility issues with 10.10 Yosemite. 

Please do not hesitate to contact us with any specific issues or questions you may have. 

Thanks for your patience. 

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.
Powered by Zendesk